Please login or register.
Login with username, password and session length

UNYSOC.ORG - Upstate NY Subaru Owners Club

July 19, 2018, 03:11:54 AM
Pages: 1 [2]   Go Down

Author Topic: did I blow my turbo?  (Read 3982 times)

0 Members and 1 Guest are viewing this topic.

Offline RE543

  • Senior Member
  • ***
  • Posts: 381
  • Karma: +11/-4

Re: did I blow my turbo?
« Reply #25 on: May 20, 2014, 06:27:15 PM »
Could it maybe be a collapse cat? I stopped at synapses turbo today and they said its probably a collapsed cat
05 wrx, 02 7.3 powerstroke. Subarus and counting 12plus

Offline hydrochloric

  • Waaaay to much time on their hands!
  • *****
  • Posts: 3,729
  • Karma: +85/-612
  • Car potpourri is my speciality!

Re: did I blow my turbo?
« Reply #26 on: May 21, 2014, 12:03:59 AM »
You would have the cat after the turbo on that model, so if it were clogged the backpressure would prevent the turbo from spooling well...  But beyond that I've got nothing for you.  Too deep into turbo territory for my supercharged brain.
-'00 BRP 2.5RS- rustbucket DD with SUPERCHARGED! junkyard engine  :D  -'66 VW Type III 1600 Squareback- Survivor, 42k miles  -'83 944- mostly-un-broken track car  -'50 Hudson Commodore 6 TSD rally car  -'93 Audi S4- New DD.  Eventually.

Offline skyphix

  • Waaaay to much time on their hands!
  • *****
  • Posts: 5,379
  • Karma: +126/-40
    • http://www.skyphix.com

Re: did I blow my turbo?
« Reply #27 on: May 21, 2014, 12:05:53 PM »
Have you pulled the intercooler and checked the y pipe yet?
Eric

Offline RE543

  • Senior Member
  • ***
  • Posts: 381
  • Karma: +11/-4

Re: did I blow my turbo?
« Reply #28 on: May 21, 2014, 04:47:43 PM »
Yes I checked all piping and everything is fine. Pulled the downpipe off and my 2nd cat is wedged sideways in the housing.  I smashed it out then cleaned the housing and put it back together. Car runs fime now. Dont I feel stupid thinking it was a boost leak.  But the dogging, loud spool noises and quiet exhaust just made me think it was getting no boost and there was an open line ot something somewhere
05 wrx, 02 7.3 powerstroke. Subarus and counting 12plus

Offline Kavik

  • Waaaay to much time on their hands!
  • *****
  • Posts: 9,999
  • Karma: +305/-268

Re: did I blow my turbo?
« Reply #29 on: May 21, 2014, 05:05:16 PM »
should've smashed out the other one while you had it off......"stage 2" with a tune, without having to worry about buying a catless dp or failing visual inspections  :mrgreen:
(still stuck having the flat plate design instead of a bellmouth or split pipe, but still.....it'd be something lol)

glad you were able to sort it out and it didn't end up being expensive  :mrgreen:
-Daryl (Albany)                                                                                   ಠ_ಠ
['14 Mazda3 SGT]     ['03 Sonic Yellow WRX Wagon]     ['05 WRB WRX Wagon]     ['02 PSM WRX Sedan]

Offline Evil Jesus

  • ScoobyDooby Specialist
  • ****
  • Posts: 630
  • Karma: +6/-1
  • TOYOBARU!

Re: did I blow my turbo?
« Reply #30 on: May 21, 2014, 05:37:23 PM »
Great job on the fix!  I hope you're out giving it the beans right now!

Offline RE543

  • Senior Member
  • ***
  • Posts: 381
  • Karma: +11/-4

Re: did I blow my turbo?
« Reply #31 on: May 21, 2014, 07:07:12 PM »
I plan on picking up pitmans dp and acess port this weekend if all works out so ill be getting rid of this pipe soon anyway.  And it really does pull like a freight train now.  Good to have speed back.
05 wrx, 02 7.3 powerstroke. Subarus and counting 12plus
Pages: 1 [2]   Go Up